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enhancements. If there are any 'bugs', they can normally be cleared within 24 hours and revised 
software files are available for download from our web immediately.    Please e-mail your comments, 
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Copyright, Registration, Technical Support

This system was developed by Informatik Inc, P.O. Box 868, Devon, Pennsylvania 19333.    For 
information on program modifications, systems integrations and custom applications, please contact 
Informatik Inc.

This is a copyright-protected shareware product.    If, after review and evaluation, you like the 
software, please register and pay the registration fee.    Upon registration and payment of the 
registration fee, Informatik Inc will send you the latest master diskette, a print file of the User Guide 
and a registration certificate.    Registered users will receive lifetime technical support and are 
entitled to free software upgrades during first year.    Shareware is based on trust, and we hope that 
all users will register. 

To register

From the About menu, choose Registration, Copyright and follow the instructions.

To obtain technical support

From the Help menu, choose Technical Support and follow the instructions.

© 1995-1996 Informatik Inc
All rights reserved



Text

Use the Text column to insert fixed (constant) text or to concatenate/merge field values and/or text 
strings.    To enter a value, click on the cell in the Text column and type the text in the prompt box.

The text entered is formatted according to the formatting specifications in the Format Column.

Concatenation, Merge
 
References to field numbers must be enclosed in brackets.    The concatenation can include 
characters, spaces, and field references.    If you concatenate two fields and you wish to insert a 
space between the two values, you must place a space between the bracketed field references.    
Example of a concatenated text with field references:    Born on [1] at [2]

If you concatenate several fields and some fields are blank, the resulting concatenation may include 
unwanted blank spaces.    These blanks can be trimmed with the Trim formatting functions.    
Embedded double-spaces can be trimmed with the All Trim format function.



Comma-Delimited Files

1. From the Methods menu, select the 'Reformat Comma-Delimited File'.    The ASCII Conversion 
Specification window is displayed.    From the File menu, choose Open ASCII File (or click on the
red folder button).    Select the file and press OK. The display shows the fields of the delimited 
ASCII file with specimen entries.

2. In the Destination Lineup column, specify the sequence of the fields for the destination file.    
Click on the field that you want to change and select a field from the displayed list on your right.   
From the Edit menu, choose Insert Item or Remove Item to insert or remove line items.    To clear
the screen, choose Clear Screen from the Edit menu.    To re-populate (refresh) the screen with 
the current ASCII file, choose Populate Destination Lineup from the Edit menu.

3. Specify the Text and the Format. 

If the Destination Lineup is blank but you enter a Text or a Format, the system uses the field 
number of the source file or the next sequential field.

4. Save the specifications.    From the File menu, choose Save Spec File (or Save As) and press 
OK.

5. To execute the conversion, choose Execute.

6. The converted file will be saved in the TEMP.TXT file in the application's directory.    If the file 
already exists, the data will be appended.    To delete the TEMP.TXT file, choose Delete 
TEMP.TXT File from the File menu.

7. To view the converted file, choose View from the File menu.    The system uses Notepad as a 
viewer.    If the file is longer than 32,000 bytes you must use another viewer.

8. To clear the screen, choose Clear Screen from the Edit menu.

Save the conversion specifications

1. From the File menu, choose Save Spec File (or Save As)..    

2. In the dialog box, specify the file name.    The extension must be ASC.    If you leave the 
extension blank, the system will append the correct extension name.    

3. Press OK.

Retrieve saved conversion specifications

1. From the File menu, choose Open.

2. In the Open dialog box, select the file.    Press OK.

View the converted file



1. From the File menu, choose View TEMP.TXT file.    The system uses Notepad as a viewer.    If 
the file is longer than 32,000 bytes you must use another viewer.

Delete the TEMP.TXT file

1. From the File menu, choose Delete TEMP.TXT file.    Press OK.



Formatting

The Formatting option allows you to format the text.    To specify a format, click the cell in the Format 
column and select the format from the displayed list.

You may specify a format that is not listed, by choosing Customize from the list.    Be sure that the 
format is system-compatible. At the end of this topic you will find s a list of common format elements. 
Please also read the section below on 'Mask'.    Masking allows you to restructure and reconstruct 
the value in a field.

You may also permanently add your own formats to the list.    These added formats must be listed in 
the FORMATS.TXT file in the applications directory.      Use any text editor and enter one format per 
line.    The FORMATS.TXT will be appended (not replacing) to the standard list of formats.

The standard formats are:

Upper Case, Lower Case, Proper Case

The text will be converted to upper or lower case characters.    The Proper Case format converts the 
first character to upper and all other characters to lower case.

Left Trim, Right Trim, All Trim

Blank spaces to the left or right are eliminated.    All Trim eliminates the spaces on the left and the 
right plus all embedded multiple spaces.

Alpha

The Alpha formatting option ensures that the field is encapsulated in quotation marks, even though 
the source file may not use encapsulation for numeric fields.
    
Numeric

The Alpha formatting option ensures that the field is NOT encapsulated in quotation marks if it is a 
numeric field.    The system will abort if it encounters a non-numeric value in the field.

Truncate

The converted field values may be limited to a specific number of characters.    To truncate the field 
value, choose Truncate and enter the number of characters in the prompt box.
Blank

This option creates a blank field.

mm/dd/yy

Example: 05/08/95

mmddyy



Example: 050895

yymmdd

Example: 950508

#0.00

Example: 1000.00

#,##0.00

 Example: 1,000.00 

Commonly used format elements:

d day without the leading zero (1-31)
dd day with leading zero (01-31)
ddd day (Mon-Sun)
w day of the week (1-7) where 1 is Sunday
ww week of the year (1-53)
m month without leading zero (1-12)
mm month with leading zeros (01-12)
mmm name of month (Jan-Dec)
y day of the year (1-366)
yy two-digit year (00-99)
yyyy four-digit year (100-9999)
# placeholder for numeric values

Example: #,##0.00##    shows a minimum of two decimal places with a maximum of four 
decimals places.    Amounts higher than 999.99 include a 'thousands separator'.

For a complete list of all format codes, please visit the web page 
http://users.aol.com/informatik/formats.html.

Mask

The Mask function allows you to rearrange and reorganize the text in a field.    The characters can be
re-sequenced, inserted and/or removed.    The Mask function is operated via the Customize Format 
option.    As a format, simply enter the mask specification, as demonstrated in the following example:

mask=[5][6]/[1][2]/[3][4]

This example would convert the text 123196 to 96/12/31

Explained:    mask= is a keyword that initiates the masking process.    The numbers in square 
brackets represent the ordinal number of the character to be inserted.    For example [5] brings in the
fifth character of the field and places it in the first position; [6] brings in the sixth character and places
it in the second position. The slashes (/) are inserted characters.



Rules:Character positions are shown in square brackets.    Literal characters are inserted at the 
appropriate position.    You cannot insert square bracket symbols ([ and ]) into the text.



Tutorial

1 To run this tutorial, you need a comma-delimited ASCII text file.      From the Methods menu of the
blank AsciiConvert window, choose Convert Comma-Delimited.      The Ascii Conversion 
Specification window is displayed.

2.  Open Ascii File (red folder button).    In the Open dialog box, specify the comma-delimited Ascii 
file that you want to convert.    Press OK.    The screen displays the fields of the delimited Ascii 
file with specimen data entries.

3. In the Destination Lineup column, specify the new sequence of the data fields.    Simply click the 
cell that you wish to change and select a field from the displayed list on your right.    To refresh 
the lineup, choose Populate Destination Lineup from the Edit menu. To clear the screen, choose 
Clear Screen from the Edit menu.    Fields can be removed and new field placeholders can be 
added by choosing Insert Item or Remove Item from the Edit menu..

4. In the Text column, you may specify a fixed or constant text that will override any text in the 
source file.    To make an entry, click on the cell and type the text in the popup input box.    The 
entry can be plain text, or field concatenations and merge.    Field references must be entered in 
brackets.    For example, if you wish to concatenate field 1 with field 2 with the word 'as' in 
between, simply type [1] as [2].    

5. In the Format column, you may specify the formats, from a large list of options.    To enter a 
format, click on the cell and select the format from the displayed list.    To create your own format,
choose Customize.

You may add your own formats to the list by creating a FORMATS.TXT file in the applications 
directory.    Each format must be on a separate line.    The entries in the FORMATS.TXT file will 
be appended to the programmed list.    Use any text editor, e.g. Notepad, to create and save the 
file.

6. Once you have specified the conversion, you should save the specifications for later re-
application.    From the File menu, choose Save Spec File ( or Save As).    In the prompt specify 
the file name.    The extension must be ASC or blank.    Press OK.

7. You are now ready to run the conversion.    Press the Execute button.    To stop or abort the 
conversion, press the Stop button.    

The converted file will be saved in the TEMP.TXT file in the applications directory.    If the 
TEMP.TXT file already exists, you should delete the file first, unless you want to append to the 
file.    You can delete the TEMP.TXT file by choosing Delete TEMP.TXT file from the File menu.

8. When the conversion is complete, you should review the results .    From the File menu, choose 
View TEMP.TXT File.    This option will open the Notepad viewer and display the converted file.    
If the file is longer than 32,000 bytes, you must use another viewer, such as Windows Write.

9. To close the system, press on Close or choose Close from the File menu. 



Vertical Lists

AsciiConvert can convert the comma-delimited ASCII file to a plain vertical list, where each line 
represents a field.    The records are separated by a blank line.    

Blank fields can be compressed or printed as blank lines.

1. From the Methods menu of the main screen (all windows closed), choose Create Vertical List. 

2. Click on the Source File box and specify the source file name.

3. Click on the Destination File box and specify the destination file name.

4. If you want to print the blank fields as separate blank lines, remove the check mark in the 
Compress checkbox.

5. Choose Execute.



Fixed-Width to Comma-Delimited Conversion

You can convert a fixed length random file to a comma-delimited ASCII file.    The conversion 
requires a specification file.    This specification file is a text file that can be created with any text 
editor, for example the Windows Notepad.    You can give the file any name and place it in any 
directory.    The following is an example of a specification file:

1,30
31,10
41,13n
54,13n
80,10
67,13n

Each field is specified on a separate line; no blank lines.
The first number is the starting position of the field.
The second value (after a comma) is the length of the field.
An optional n at the end of the line creates a numeric field.

The system builds a comma-delimited ASCII file in the specified sequence.    

To run the program:

1. From the Methods menu of the main menu (all windows closed), choose Fixed Length Files.    
The Fixed-Width to Comma-Delimited window is displayed.

2. Click on the Source File box and choose the source file.

3. Click on the Destination File and specify the destination file (with extension).

4. Click on the Specification File and choose the specification file.

5. Click on Execute.



Comma-Delimited to Fixed-Width Conversion

You can convert a comma-delimited file to fixed-width file.    The conversion requires a specification 
file.    This specification file is a text file that can be created with any text editor, for example the 
Windows Notepad.    You can give the file any name and place it in any directory.    The following is 
an example of a specification file:

10,L
10,R
5,Z

Each field is specified on a separate line; no blank lines.
The first number represents the number of characters in the field.
The second value (after a comma) is the mandatory alignment and filler specification
            L = left adjust
            R = right adjust
            Z = zero-fill (to the left)
.
If the field is longer than the specified width, the field will be truncated.

To run the program:

1. From the Methods menu of the main menu (all windows closed), choose Comma-Delimited 
to Fixed Width.    The Comma-Delimited to Fixed Width Conversion window is displayed.

2. Click on the Source File box and choose the source file.

3. Click on the Destination File and specify the destination file (with extension).

4. Click on the Specification File and choose the specification file.

5. Click on Execute.



Fixed-Width File Builder

You can build your own fixed-width file.    The system provides a simple text box for your entry.    As 
you enter your text, the system indicates the position of the next character.    If you highlight a string, 
the system indicates the beginning point, ending point and the length of the highlighted string.

To run the program:

1. From the Methods menu of the main menu (all windows closed), choose Fixed-Width File 
Builder.    The Fixed-Width File Builder window is displayed.

2. Enter your text.

3. From the File menu, chose Save (As) and save the file.



Combine Files

You can combine files by appending a selected file to the WORKFILE.TXT file.

To combine files:

1. From the Methods menu of the main menu (all windows closed), choose Combine Files.    
The Combine Files window is displayed.

2. Click on the Proceed button. 

3. In the pop-up dialog box, specify the file that you want to append.

4. The file is appended to the WORKFILE.TXT file.    

5. In your Windows File Manager, rename the WORKFILE.TXT file.

If the WORKFILE.TXT is not empty, the system will alert you.    Confirm, or click on Delete 
WORKFILE.TXT in the File menu to clear the file.



Miscellaneous Delimiters to CommaDelimited Conversion

Files with a miscellaneous delimiters can be converted to commadelimited files.    Once converted to 
commadelimited, the file can be manipulated with the CommaDelimited File Conversion option, 
described above.

1. From the Methods menu of the main menu (all windows closed), choose Miscellaneous to 
CommaDelimited.    The Miscellaneous to CommaDelimited    window is displayed.

2. Click on the Source File box and choose the source file.

3. Click on the Destination File and specify the destination file (with extension).

4. Specify the delimiter.    The delimiter may be a single character of a group of characters.

5. Click on Execute.



HTML Table Tags

Comma-delimited files can be converted to the HTML table format with <TD> tags.    The converted 
file can then be copied to the Clipboard and pasted into the HTML document for web publishing.

1. From the Methods menu of the main menu (all windows closed), choose HTML Table Tags.    
The HTML Table Tag    window is displayed.

2. Click on the Source File box and choose the source file.

3. Click on the Destination File and specify the destination file (with extension).

4. Click on Execute.



Tab-Separated to Comma-Delimited Conversion

1. From the Methods menu of the main menu (all windows closed), choose Tab-Separated to 
Comma-Delimited.    The Tab-Separated    window is displayed.

2. Click on the Source File box and choose the source file.

3. Click on the Destination File and specify the destination file (with extension).

4. Click on Execute.




